[realtek] Flashing EPROMs on a DFE-530TX+?

Donald Becker becker@scyld.com
Wed, 15 Aug 2001 11:00:36 -0400 (EDT)

On Tue, 14 Aug 2001 asincero@arcadio.net wrote:

> uses a Realtek RTL-8139C chip.  This NIC should be able to flash program a
> flash eprom plugged into its boot rom socket, right?

Correct, for the 'B' and 'C' parts.

>  But when I try to
> flash an Atmel AT29C256-12PC thats plugged into the boot rom socket using
> the rtl8139-diag utility (with libflash.c linked in) I get the following
> message:
> libflash.c:v2.03 4/19/2000 Copyright Donald Becker, becker@scyld.com  
> This is an unknown flash chip, which cannot be programmed.
> rtl8139-diag.c:v2.03 5/15/2001 Donald Becker (becker@scyld.com)
>  Would write new Default Media entry 0x0000 to offset 6, the current value is 0xe112.

Note: the recent update corrects this bug but does not change the Flash

> Hmmm, no response to the ID command, trying again..
> ACKKK, this may not be a programmable Flash part!
> Unknown BIOS ROM ID 00 00.

Hmmm, it's not an unrecognized new part, the code isn't reading the ID
at all.

> Anybody have any ideas?  What would happen if I hacked libflash.c to bypass
> trying to identify the flash chip and tell it directly that its an Atmel
> AT29C256 by hardcoding it in?

It's worth a try.  If the part is empty, you have no risk.
If the part is already programmed, try reading the contents to see if
any non-zero data can be read.

> FWIW, I tried using the DOS Realtek flash utility, RTFLASH.EXE, I got from
> ftp.realtek.com.tw.  However, that quickly turned out to be a deadend
> because when I tried to use it it said it couldn't find the ethernet card
> :-(.  Which is kind of annoying because the DOS Realtek diagnostic and setup
> utility, RSET8139.EXE, is able to see and configure it just fine.

The D-Link part has a unique PCI ID.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993