[realtek] Flashing EPROMs on a DFE-530TX+?

asincero@arcadio.net asincero@arcadio.net
Tue, 14 Aug 2001 23:00:02 -0400

Hello list,

I have a D-Link DFE-530TX+ NIC.  According to the 8139too driver, this thing
uses a Realtek RTL-8139C chip.  This NIC should be able to flash program a
flash eprom plugged into its boot rom socket, right?  But when I try to
flash an Atmel AT29C256-12PC thats plugged into the boot rom socket using
the rtl8139-diag utility (with libflash.c linked in) I get the following

libflash.c:v2.03 4/19/2000 Copyright Donald Becker, becker@scyld.com  
This is an unknown flash chip, which cannot be programmed.
Failed to load the new Flash BootROM image from file 'eb-5.0.2-mc1-rtl8139.lzrom'.
rtl8139-diag.c:v2.03 5/15/2001 Donald Becker (becker@scyld.com)
Index #1: Found a D-Link DFE-538TX (RealTek RTL8139) adapter at 0xc800.
EEPROM size test returned 6, 0x204a4 / 0x2.
 Would write new Default Media entry 0x0000 to offset 6, the current value is 0xe112.
Hmmm, no response to the ID command, trying again..
ACKKK, this may not be a programmable Flash part!
Unknown BIOS ROM ID 00 00.
 Use '-a' or '-aa' to show device registers,
     '-e' to show EEPROM contents, -ee for parsed contents,
  or '-m' or '-mm' to show MII management registers.

Anybody have any ideas?  What would happen if I hacked libflash.c to bypass
trying to identify the flash chip and tell it directly that its an Atmel
AT29C256 by hardcoding it in?

FWIW, I tried using the DOS Realtek flash utility, RTFLASH.EXE, I got from
ftp.realtek.com.tw.  However, that quickly turned out to be a deadend
because when I tried to use it it said it couldn't find the ethernet card
:-(.  Which is kind of annoying because the DOS Realtek diagnostic and setup
utility, RSET8139.EXE, is able to see and configure it just fine.

Thanks in advance for any help with this.

- Arcadio