[realtek] Can't compile on RedHat 7.0 after reading instructions

Angus Palmer angus_palmer@hotmail.com
Mon, 09 Apr 2001 01:08:19 +1000

I was running kernel 2.4.1 with the rtl8139 driver with no problems until I 
had to re-build my kernel for fat32 support. I've managed to get my other 
modules to work such as the NVidia driver and emu10k1 but i can't get the 
rtl8139 to work again. The actual card in use is a D-Link DE528CT and 
everytime during boot i get the error:
delaying eth0 initialisation    [FAILED]

My modules.conf has the line 'alias eth0 rtl8139' as per the installation 
instructions but i get errors when running depmod complaining about 
unresolved symbols.
I tried compiling the latest source code using the compile arguments at the 
end of the source file but got errors such as:
rtl8139.c:XXXX: structure has no member named 'tbusy'

i then followed the instructions for users with RedHat and it's dodgy 
compiler but i couldn't find any other versions of gcc or kgcc. My current 
version of gcc is 2.96 and was used to build the kernel so i figured it must 
be okay.
Secondly i added the '-I/root/linux/include' argument to the argument list 
for gcc(coz thats where i built the new kernel). However i still get the 
same errors :(

When compiling the latest source didn't work, i decided to try and find my 
original driver that worked before. The only reference to rtl8139.o I could 
find was in /lib/modules/2.2.XX/net/rtl8139.o which is RedHat's precompiled 
module tree. My previous working version of 2.4.1 had it's module tree 
renamed to /lib/modules/2.4.1OLD so that running 'make modules_install' a 
second time wouldn't overwrite it. I don't know why i couldn't find 
rtl8139.o in /lib/modules/2.4.1OLD or even find the 
/lib/modules/2.4.1OLD/net directory where this driver should be.
Anyhow i tried to 'insmod rtl8139.o' and that spat out a whole lot of errors 
about unresolved symbols aswell.

The last thing i have done is gone and made sure that i specified support 
for Realtek cards when running 'make xconfig' This is where i realised it 
was set to no. I hadn't run 'make mrproper' at this time so it had kept my 
previous settings. I specified to load support as modules and then rebuilt 
the kernel and did 'make modules' followed by 'make modules_install'
After rebooting i tried everything i had tried before and still no luck.
Can someone help plz? as this is really frustrating!

Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.