[realtek] Fw: Can't load RTL8139.o module Rhat 6.2

Paul paul2x@hotmail.com
Thu, 21 Sep 2000 02:57:05 -0700

I'm new at Linux, so go easy on me. I've just download and installed the
Redhat distribution of Linux version 6.2 (2.2.14). Before attempting to
compile a new module from the files on this site, I've made sure to read
through all the archives to try and resolve the problem with the module
supplied with Redhat. Anyway, here's what I've got. I have a Trendware
ethernet card with the RTL8139B chip. When using either the "modprobe" or
"insmod" commands, a message is returned, "Device or resource busy". I tried
referencing the archives as much as possible to try all suggestions. I have
turned off the PNP OS option in my bios and have also tried assigning an IRQ
to the card as well as letting it autoconfig. Currently I have it set to IRQ
11 which does not conflict with any other IRQ's. Also, when I boot Windows
it is indeed reported as IRQ 11 at IO d800.

Here are some of the contents of files that I believe are relevant:

cat /proc/pci

Bus 0, device 11 function 0:
    Ethernet controller: Unknown vendor Unknown device (rev 16)
        Vendor id=1. Device id=8139.
        Medium devsel. Fast back-to-back capable. IRQ 11. Master Capable.
Latency=32. Min Gnt=32.Maz Lat=64
        I/O at 0xd800 [0xd801]
        Non-prefetchable 32 bit memory at [0xd7800000]

cat /proc/interrupts

   0:         534705               XT-PIC    timer
   1:            1896                XT-PIC   keyboard
   2:                 0                XT-PIC   cascade
   8:                 1                XT-PIC   rtc
  12:            519                XT-PIC   PS/2 Mouse
  13:                1                XT-PIC   fpu
  14:          95168               XT-PIC   ide0
  15:                 3               XT-PIC   ide1
MNI:                 0

I'm looking for any direction for troubleshooting this type of problem. I
believe I have exhausted everything that I have found in the archives. I did
at one point try to recompile the newest files found here on the site, but
received a parsing error which I did find in your archives. Apparently a bug
in GCC??? according to the only message I found in the archive regarding
this type of error, I'll worry about this later if it comes down to to. I
would first like to try and troubleshoot.

I tried to call Trendware before troubling anyone here, but they actually
referred me to this website. I also tried the RedHat knowledge base, but
consistently get "404" page errors indicating the pages can't be found. So
any help or direction would be much appreciated.

Thanks in advance Paul.