[realtek] RX-Problems with RTL8139

Thomas.Friedrichsmeier@ruhr-uni-bochum.de Thomas.Friedrichsmeier@ruhr-uni-bochum.de
Fri, 23 Jun 2000 16:47:48 +0200

Hello there!

I hope someone can help me with the following problem:
I recently installed an RTL8139-card into my Linux-Server. After 
several hours, download of the latest driver and the usual problems 
everything seemed to work out fine (ping etc.).

However, when trying to copy files larger than a few KB to the 
server (from a Win98-Samba-Client), the transfer-rates drop to 
something not very much faster than ISDN.
Then netstat-command shows me incredible numbers of RX-errors, 
yet virtually no TX-errors. I tried ping -f (server to client) using 
different packet sizes and got perfect transmission with packet 
sizes up to some 2000 bytes, above that errors rapidly increased 
and hardly any packets got transmitted correctly. (This too, 
produces zillions of RX-errors but no TX-errors).
Interestingly, when I force the link to 10base-T, I get normal speed 
and everything works just fine, so this is what I'm currently working 
I read, that old-PCI-mainboards might have trouble with long PCI-
Bursts. My mainboard definitely looks really antique. It's a 
Pentium66 with PCI and VESA-Local-Bus. So I changed the 
setting of RX_DMA-BURST_LEN (or whatever the name of that 
option was, I'm currently not at home and can't look it up) to 1 (a 
setting I saw recommended in some mail in the archive of this list) 
or even to 0. However, it didn't seem to produce any effect at all 
(yes, I did recompile/restart).
Of course I've also watched the hub, but it hardly shows any 
collisions at all.

I hope someone can help me.


PS.: I don't know too much about networking, but I was once told, 
that regular hubs will not support full-duplex. When auto-
negotiating, my card always ends up with full-duplex-mode. Of 
course I tried forcing the card into half-duplex, but I doesn't seem to 
have any effect, neither for 10 nor for 100 Mbits (that is, either way 
it works at 10 Mbits but not at 100Mbits).