[realtek-bug] 8319 Card hangs under heavy load

Aaron D. Marasco Aaron@Marasco.com
Sat, 07 Jul 2001 12:06:46 -0400

I used to have this problem, but it was fixed in one of the 2.2.x kernels. 
Then it popped up again in 2.4.x. I worked with the author a few weekends 
ago to get 8139too fixed and it seems that the changes were rolled into 
official kernel 2.4.6.

However, my problem was worse. My Linux box would totally lock up and die. 
Nothing worked at all, not even the simple shell script that is always 
running blinking the keyboard lites to tell me it is alive - it wasn't.

There were a bunch of changes, but the "final" one for me was this:

>in function rtl8139_start_xmit, around line 1704 move the line
>         spin_lock_irqsave (&tp->lock, flags);
>to -above- the following lines,
>         /* Calculate the next Tx descriptor entry. */
>         entry = tp->cur_tx % NUM_TX_DESC;

Don't know if that alone did it or was the final fix with all the other 
code scrambling. There may be something similar in the original code (which 
I preferred, but need 2.4.x for iptables).

  - Aaron

Aaron D. Marasco