linux hangs after some ftp traffic

Anthony Schlemmer
Mon Jul 5 18:22:17 1999

I'm no expert on the Epic100 drivers but I do have 3 Linux systems and 1
Win 95 system that are using the 9432TX cards in 100BaseTX mode on my
home network. Two systems are SuSE 6.0 running with 2.0.36 kernel with
version 1.04 of the epic100 driver. The third system is a SuSE 6.1
system with a 2.2.10 kernel and it too is running with the 1.04 Epic100
driver.  The phone lines where I live are pretty poor and so my internet
connection limited to a dialup PPP connection. With such a low bandwidth
internet connection my network is not stressed all that hard. I do
routinly do some rather large file copies either using FTP or via NFS on
shared drives and the Epic 100 drivers appear to be fairly stable. 

It's been nearly a year since I first started using the EtherPower II
cards. The version 0.99B through 1.01 drivers were very unstable for me
and I had alot of problems with TX timouts. As a stop gap measure I
replaced my 100 megabit hub with a 10BaseT one and ran my network in a
degraded state until version 1.02 of the drivers were released. Since
I've been running with the newer 1.02 or higher drivers my systems have
been quite stable.

I saw some posts some months back where people were noting problems
caused by race conditions or something like that. The big problem I see
is that the archives for the Epic 100 mailing list are no longer being
updated. I checked today and the last archive entries are from November
1998. Unfortunately that means that users just subscribing to this list
can't really see what problems and/or solutions have been posted

Nick Busigin wrote:
> On Mon, 5 Jul 1999, maDDog wrote:
> > i have the following problem with the SMC 9432 BTX card :
> > 1. BNC wont work (even under win98 but thats not important) (even if i
> > set options=1)
> I couldn't get the 10 MB BNC networking to work either, but didn't really
> try too hard as I was more interested in getting the 100 MBit networking
> going (which won't work through the BNC connection).  (I just happened to
> have some coaxial cable handy and tried to use it while I waited to have
> my 100 BaseTX cable made up).
> > the linux server got suse 5.3 installed (kernel 2.0.35) with wuftpd
> >
> > do i have do use some tricks with rx_copybreak or others to solve this
> > problem ?
> Currently, I'm running a Debian Gnu/Linux system with a 2.0.35 kernel and
> it's working great.  So I imagine that you should be able to have the same
> success.  I'd be more than willing to send you a copy of the epic100.c
> driver code via email if you'd like.  I have the epic driver compiled as a
> module and have it set to load at boot by having the following one-line
> entry in my /etc/modules file:
> epic100
> Note that I did run into problems getting the driver to work with some
> other versions of the Linux kernel.  That's why I'm using the 2.0.35
> version rather than a later version.  I'm not sure why it didn't work with
> later versions of the kernel (I only tried 2.0.36 and 2.0.37) and I do
> believe that others have been successful with later versions.  Someone
> care to comment on why this is the case?
> Best regards,
>                                 Nick
> --------------------------------------------------------------------------
> Nick Busigin  ...Sent from my Debian GNU/Linux Machine...
> To obtain my pgp public key, email me with the subject: "get pgp-key"
> --------------------------------------------------------------------------
>  | To unsubscribe, send mail to, and within the
>  |  body of the mail, include only the text:
>  |   unsubscribe this-list-name
>  | You will be unsubscribed as speedily as possible.


 | To unsubscribe, send mail to, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name
 | You will be unsubscribed as speedily as possible.