[eepro100] eepro100 in a MSI K7D master

Josť Josť
Mon Jan 13 13:11:01 2003


Dear all

We are trying to install SuSE linux 8.1 in a computer based in a MSI K7D 
MASER motherboard. The board has the ethernet card integrated (Intel 
82559ER). The card is properly recognized by SuSE and configured, giving 
reasonable answer to a ifconfig command. However, the internet connection 
does not work at all. This means that we cannot even execute a simple ping 
command (unless a ping to its own IP address). After fighting for a while 
with the problem, we installed Mandrake 9.0. With this distribution, the 
board worked just fine! The only two differences that we found between both 
distributions were the IRQ: (SuSE 11, Mandrake 17) and the driver: (SuSE 
e100, Mandrake eepro100). We manually forced SuSE to load eepro100 but the 
network did not worked, so I assume that the eepro distributed by SuSE is 
old and does not work with my motherboard. So the question is (I know, for 
most of you is stupid): how can I find the version of the eepro100 that 
SuSE is installing? Did anybody find this problem and solved it?

Yea! I can read your minds: why don't I switch to Mandrake? 'cuz what I am 
trying to set up is a node in a cluster of PCs running under SuSE.

Than in advance for your help


JAF