[eepro100] Intel Ethernet card on Linux woes

Donald Becker becker@scyld.com
Sat Sep 14 07:59:01 2002

On Sun, 8 Sep 2002, Nikhil Deo wrote:

> I have a system running RH7.2 that has 10/100 Intel® Pro integrated network
> card.

It should work fine, assuming that we are talking about the usual modern
NIC, not an 1995 era ISA NIC with a similar name. 

> First of all, I hope eepro100/e100 is the right driver for this
> card. I forgot where I had seen that info.
> insmod fails with a init_module: No such device 

Which driver version are you using?  You will need something fairly
recent to detect one of the new integrated chipset NICs.

> I had found out that the IO of the card is 0xd000 and then also tried putting
> the line options eepro io=0xd000 after the alias eth0 eepro in the
> modules.conf file. I also tried telling explicitely to use IRQ 10. 
> I also tried an 'autodetect=1' 

The ISA-style options are not used with PCI devices drivers, and any
unrecognized option name will keep a module from loading.

> In one of the combinations I also had the following messages in dmesg
> eepro_init_module: Probe is very dangerous in ISA cards
> eepro_init_module: Please add "autodetect=1"

The driver is 'eepro100' not 'eepro'.  That might be your problem.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993