[eepro100] Re: eepro100 digest

Mike Sullivan mike@oddjob.utias.utoronto.ca
Wed Nov 14 12:18:01 2001


Thanks for the responses.  It seems to be an issue with something redhat has
done, I have gotten nowhere on related forums. I was hoping that someone
who knows a great deal more than I do about the flow of data through the
various software layers might be able to suggest a possible fix.  Some
more points.

A kernel from RH 7.1 that workd under 7.1 does not work under 7.2.

I have tried compiling several kernels by hand. Differing only in the selection
of SMP enabled. The SMP ones do not work the uni versions do. Enabling SMP
for my machine breaks one of the software layers.

I had assumed it was the transciever as the card seems to setup ok and the driver
reports no probs. I ran the mii-diag tool and the eepro100-diag tool from scyld
and no problems were reported and link beats were detected.

I stuck in a tulip based card and get the exact same behaviour so it does not
appear to be a problem with the driver, at least not a prob unique to this one.

I do not want to use other distros as I am part of a large group that also has
Alpha machines so I want to be fairly uniform in the software setup.

I will try to get a 2.2.x kernel to work and will post the result.

                                                                                                        Regards All
                                                                                                        Mike Sullivan

> > Dear users
> >
> > It amazes me that people have problems wit the eepro 100 on SMP systems
> > with the 2.4.x kernels - Using Slackware 7.1 or Slackware 8 I encounted
> > no problems at all. Admittedly I manually build a kernel to match our
> > needs.
> I agree -- I've only had one issue with the kernel driver, and replacing the
> dual-port nic with two singles fixed it.  Running a combination of 2.2 and
> 2.4, all under slack 7.1 or 8.
> John