[eepro100] problem with Debian woody freeze (possibly eepro 100 problem)

Faheem Mitha faheem@email.unc.edu
Sun Dec 23 12:33:00 2001

On Sun, 23 Dec 2001, Donald Becker wrote:

> On Sat, 22 Dec 2001, Faheem Mitha wrote:
> > I recently installed Debian Woody on a IBM Netvista 6792. The network card
> > is the Intel 100 Pro VE. The standard drive for this appears to be the
> > eepro100. I'm using the standard kernel shipped with Debian Potato/Woody,
> > 2.2.19pre17. The card was configured automatically for me by Debian using
> > eepro100 and dchp. Don't know the details, but can investigate.
> >
> > when I try to run apt (apt-get whatever) which downloads files off the
> > net, it works fine for a bit, but then comes to a grinding halt, and
> > completely freezes the machine. After this not even the power button
> > responds. The only way to restart the computer is to pull the power plug.
> This detail pretty clearly points to a hardware problem.  A driver
> shouldn't be able to hang the machine in such a way that the power
> switch doesn't work.

I dunno. There is a big round switch to the left of the front of the
machine and usually when I push it in, it reboots. However, in this freeze
situation, a simple push does not suffice. However, someone on Debian user
suggested that I push it in and hold it for 4 seconds. That works; ie. the
machine shuts down. So my earlier post was not accurate. Let us just say
the power switch does not behave as usual. Sorry about my cluelessness; I
know little about computer hardware.

Evidence against hardware problems:

1) The machine only hangs during heavy dounloads (multiple megs). It is
stable under Windows 2000. It is stable under linux as long as heavy
downloads are not being attempted. I managed to hang it 6 times or so over
the past two days and each time while I was doing heavy downloads. It
seems to take around 1/2 a minute to 2 minutes to kick in on average,
while going 25/50 Kb per second.

2) A friend of mine in my department (these are University office
machines) installed a recent version of Redhat (7.2?) with a 2.4 kernel on
an identical machine, and he complained to me about his machine locking up
all the time. He hasn't isolated the Intel card as such but it seems very
suspect. And two new machines seem unlikely to have similar hardware

Let me add furthermore that yesterday I started sporadically getting
messages like

eepro100: cmd_wait for(some stuff) timedout with (some stuff)!

Sorry, I didn't make notes of it at the time and the messages didn't occur

Judging from other messages in the mailing list, these are quite familiar
error messages. (There is someone in September 2001 who reported similar
errors). I just tried rerunning apt a couple more times and the error
messages went away, but then the machine locked up again without warning
shortly thereafter :-) Could these messages be related to the lockup or
are they a separate problem?

> Have you tried any other kernel/driver versions?  Specifically, have you
> tried a released kernel rather than a "pre" kernel?

No. That will be my next step. I'll try 2.2.19. I'm undecided whether to
first try the Debian binary package for 2.2.19 or compile from source. If
I want to try Intel's e100 driver, I think it would be best to compile
from source.

By the way, in case it is not perfectly clear, I used the stock kernel
driver from 2.2.19pre17, and didn't give any driver options, because I had
no idea what to give. This is what I refer to as eepro100. A message on
the mailing list
http://www.tux.org/hypermail/linux-eepro100/2001-Sep/0031.html refers to
"Don's version of eepro100" as well as "Intel's e100". I know about e100
but what is "Don's version of eepro100"? I assume Don means Donald Becker.