[eepro100] Problem with eepro100 driver, ES40 SMP

Craig Tierney ctierney@hpti.com
Tue, 3 Apr 2001 16:18:50 -0600

Here is a followup to my own post.

The latest version (v1.13) of the eepro100 driver does work for my
ES40s now.  My problem ended up being that I was compiling
the driver incorrectly.  The options at the bottom of the eepro100.c
are not correct for Alpha.  Although I added the -ffixed-8 option,
more ware missing.

In the file netdrivers-2.1.6.rpm, the Makefile adds a couple of
options for the Alpha architecture:

    CFLAGS+=-pipe -mno-fp-regs -ffixed-8 -mcpu=ev5

In a nutshell:  Get the rpm and use the makefile.  It will get the
flags right for your architecture.

Things are better now. I can run 8k packets with UDP.  Other issues
are preventing me from larger packets and TCP.  


On Thu, Mar 15, 2001 at 03:27:46PM -0700, Craig Tierney wrote:
> I have been having problems with my eepro100 that came
> with my ES40.  Here is the hardware and software setup:
> - ES40 (4 proc/8 GB, 2 proc/2 GB)
> - eepro100 (Actually either a clone or a COMPAQ remark of the eepro100)
> - Extreme Networks GigE switch 
> - HP Procurve Fast Ethernet switches (uplinked to each other via GigE switch)
> - Linux 2.2.18.
> - NFS mounts from an SGI IRIX (6.5.8).
> I continue to get error messages like the following:
>   eth0: Transmit timed out: status 0050  0c00 at 228770/228830 command 000c0000
> I get this error when copying data over NFS.  The network will have
> for awhile and then resume.  After a network pause, the mii-diag program 
> reports: 
>   Link status: previously broken, but now reestablished
> Copying by scp doesn't seem to cause the problem.
> This happens when I let the nodes auto-negotiate the following
> settings:
>   100 Mb/s Half-duplex
>    10 Mb/s half-duplex
> the 100 Mb/s full-duplex gives transfer rates of about 10 KB/s so
> I don't know what is going on there.
> I have also fixed the switch at 100 Mb/s Full, 100 Mb/s Half, and 10 Mb/s
> full with no success.
> I have set the transfer size for NFS v3 reads and writes to both 8192
> and 32768 for TCP.  I have also tried NFS v3 UDP with read and write
> sizes as 8192.
> I have tried the NFS connection to a 100Mbs port on the SGI and
> also a GigE port on the SGI.
> What appears to work is NFS v3, tcp, read and write sizes at 1024.
> However, this is entirely unacceptable.  As I am only getting
> 500k per second on reads.
> I have tried building the kernel with the default eepro100 driver
> in the kernel and also as a module.
> I have tried the latest eepro100 (v1.13) from the scyld.com web site
> as a module.
> I have not tried to compile the kernel as uniprocessor.
> Numerous people have reported this or similar problems.  However, I never 
> found a definitive answer on what causes the problem and how to fix it.
> We have no problems with our XP1000s with the build in de4x5 card
> and driver.
> Any suggestions?
> Thanks,
> Craig 
> -- 
> Craig Tierney (ctierney@hpti.com)
> phone: 303-497-3112
> _______________________________________________
> eepro100 mailing list
> eepro100@scyld.com
> http://www.scyld.com/mailman/listinfo/eepro100

Craig Tierney (ctierney@hpti.com)
phone: 303-497-3112