[eepro100] Problem with eepro100 driver, v1.13, linux-2.2.19

Craig Tierney ctierney@hpti.com
Mon, 2 Apr 2001 14:45:16 -0600

I have been trying to run the latest eepro100 driver from
www.scyld.com (v1.13).  The kernel is 2.2.19.  The system
is an ES40 with 2 CPUS and 2GB ram..  The good news is that I am not 
getting my "eth0: Transmit timed out" errors.  The problem that
am having now is that when I am writing a 2 GB file over NFS,
other processes cannot startup.  I get a segmentation fault
with every new process I try to run.  Processees that are running
(like top) will continue.

The driver is loaded as:

/sbin/lsmod pci-scan.o
/sbin/lsmod eepro100 options=0x30 debug=4

The NFS mount is to an SGI server, and the options to mount


I see that klogd starts to take up 23% of the CPU during the
write, but I don't think that is significant.

I tried rsize and wsize at 1024 and did not have a problem starting
other processes.

I tried rsize and wsize at 8192 had the same problems as setting
them to 32768.

There are no errors in /var/log/messages.

The utility mii-diag reports that the card is at 100MB/full-duplex.

Does anyone have any suggestions for what I should try or other
things to look at?


Craig Tierney (ctierney@hpti.com)
phone: 303-497-3112