[eepro100] Problems at 100fd with eepro100

Vernon McPherron vernon@grooveauction.com
Fri, 19 May 2000 15:47:30 -0600 (MDT)

On Fri, 19 May 2000, Donald Becker wrote:

> On Thu, 18 May 2000, Vernon McPherron wrote:
> > On Thu, 18 May 2000, Philip Ronzone wrote:
> > > The problem is not so odd. More than one Ethernet "chip" (NIC) works fine
> > > with a hub, but has a variety of pronlems with a switch. In fact, I'm
> Writing "repeater" is more precise than "hub".
> A switch often can do full duplex, while a repeater never can.
> The usual problem with a switch is caused by the admin forcing full duplex,
> which must turn off autonegotiation, and then failing to update the settings
> when the topology changes.

Well then I guess my thinking was backwards.  I set it to full duplex when
I couldn't get it working.  But then again it didn't work on forced full

> > > I'm using the Intel e100.c driver right now, but I'm told this is NOT a
> > > driver problem, but a hardware issue.
> Hmmm, very curious.
> I could believe that Intel's  e100.c driver has bugs in common with their NT
> driver.
> Or they might mean that your Cisco or 3Com switch has broken autonegotiation.

After I posted, I downloaded all the other dirvers for the nick.  Yours,
the eepro100.c from Donald Becker's site, Andrey Savochkin's latest, and
the e100.c from intel.  Oddly enough I had problems getting the e100.c to
compile, so I tried an "old" version 1.09j or something and still
nothing.  I tried Donald's newest driver (on my SMP machine) and that
seemed to work.  I got two odd warnings at compile time, but it seems to
work great on the switch.  Andrey's wouldn't work, I tried that too.

BUT on my single cpu machine I tried to compile Donald's, and that didn't
work.  So I tried Andrey's latest and it worked great.  So for whatever
reason, I seem to have found one that works on both machines.  I belive
they are running at 100fd, but when I run the mii-diag it says Jabber, I
do remember seeing jabber vs. beat link.  (don't really know what Jabber
is)  Anyway has good performance, so I'd assume it's 100fd.

> > > From: Vernon McPherron [mailto:vernon@grooveauction.com]
> ..
> > > I've got an odd problem, I don't know if anyone else is having the same
> > > problem, but maybe I could get some help.
> > > 
> > > Not too long ago I was using a 100bt hub.  I had no problems.  But just
> > > the other day I bought a 10/100 switch.  When I hooked it up, I found out
> > > that I was having SERIOUS problems.  The module loaded fine, and I got a
> ...
> > > patched it to 2.3.99-pre8 hoping that it'd have the latest driver.  After
> ...
> > > of the pings did go through.  But I had about 95% packet loss.  Just to
> > > test it, I booted into an older non-smp kernel, and yep...  worked
> > > ok.  Unfortunately I don't want to use just one cpu.  Any ideas?
> This really sounds like just a bug in the 2.3.99 driver.
> Getting this driver working in all environments is difficult.  Those that
> though that I was refusing to put in "the obvious fix" are now finding out
> that putting the patch de jour into the distributed kernel doesn't result in
> immediate convergence to a working driver.

Is this common for just the Intel driver, or does the 3c905 have similar
problems?  (I had problems with the 3c905's just stop working.  So I moved
to the intel cards)

-- djVern --