Compaq 82558B, 82559 problems

Jason Colflesh
Tue May 25 13:26:03 1999

Okey, it looks like even though the driver doesn't like the 559's
EEPROM checksum, it's not the driver causing the hang.

This was using RedHat 6.0 (sorry I didn't make mention), and I'd
been trying DHCP, which was standard on our network.  Silly me,
I never had problems with 5.2, so didn't expect that to be the problem.
I've tested both cards with 5.2, and found it to work perfectly
with DHCP.

I had tried the 558 with static IP, and found it to sort of work
(deactivation and reactivation could cause a hang) in 6.0. Just
tried the 559 with 6.0 and static IP, and it came up.  I had
also updated the 5.2 to kernel 2.2.8 with the newest eepro100
driver, and dhcpcd 1.3.16-0.  Looks like RH6.0 uses kernel 2.2.5
with dhcpcd 1.3.17p12-1 and pump 0.6.4-1.  Pump seems to be some
new DHCP and BOOTP manager.

Anyways, I think at this point that it is one of those two daemons
that is causing the blowup. Sorry to have troubled you guys, but
you might want to bear this in mind anyhow.


Jason Colflesh                   
IT Workstation Group                                   SAP America