problems with EEPro 110+ and AIC 7890 & 3860

Donald Becker
Mon Jul 19 17:02:22 1999

On Mon, 19 Jul 1999, Christopher B. Moore wrote:

> I'm trying to set up a RedHat 6.0 based system using an Asus P2B-S
> (440BX) motherboard.  The board has an included SCSI adapter (AIC 7890
> and AIC 3860) that seems to be sharing an IRQ with the EEPro 100+.

That normally should shouldn't be a problem, now that the Adaptec drivers
have been updated.

for the old problem. 

> The eth0 device is using module eepro100.  I called redhat for support
> but was told that the EEpro100+ was "tier 3" and thus they don't care
> to help.

Hmmm, whatever.

> The problem is that the system hangs at boot when it tries to bring up
> eth0.  I've tried bringing the system up without the network and find
> that ifconfig eth0 tells me that the card is there but running ifup
> eth0 hangs the machine.  Looking at the messages file shows a bunch of
> messages the last of which reports that the rom checksum is okay.

Presumably bus mastering is OK, and the chip is basically operational.

> Can you point me where to go next to try to make this monster function
> or should I dump it and try something else?

Try putting the device on another IRQ by moving it to a different slot
and/or changing the BIOS setup.

>  I've tried to buy an
> EEPro 100 (no +) but the 100+ seems to be all that is available around
> here.

All of the boards should act the same, i82557-i82559.

Donald Becker
USRA-CESDIS, Center of Excellence in Space Data and Information Sciences.
Code 930.5, Goddard Space Flight Center,  Greenbelt, MD.  20771