Linux kernel 2.0.35 and Intep EEPro 10+/100B/100+

Nikica Petrinic
Sat Sep 26 17:26:46 1998

Dear Scott,

Thanks for replying.

At the time I posted the question I was still very much in the dark on
this issue. Not much more light now either.

Before I recompiled the kernel I checked if I was using the right module
in /etc/conf.modules. It did include eepro100. It didn't work though.

The reason why I recompiled the 2.0.35 kernel was to make use of the 
second processor (SMP). This was the first time I ever tried 
recompiling the kernel and was very careful with 'make xconfig'. However,
I wasn't successful with modules so I squeezed all I thought I needed 
into zImage.

This is what I did:
1) installed RedHat v5.1 of sunsite
2) downloaded and installed 2.0.35 kernel upgrade including sources
   (eepro100 would not work)
3) edited /usr/src/linux/Makefile to un-comment SMP=1
4) downloaded latest eepro100.c (
5) run 'make xconfig' to include relevant drivers (SCSI and eepro)
   (I can send you /usr/src/linux/.config if needed)
6) changed lilo.conf and run lilo
7) rebooted

Everything worked but EEPro.

I downloaded eepro-diag and mii-diag (following the suggestions from These
could see the card but I didn't know what to do with the information
the diags provided.

Any ideas?

I am not sure I know what this 'netatalk' is either. I don't get anything
if I type 'ps | grep netatalk'. Does that mean I am not running it?

Thanks again.


Nikica Petrinic
University Technology Centre for Solid Mechanics
Department of Engineering Science
University of Oxford
Engineering & Technology Building
Parks Road
Oxford OX1 3PJ
Tel +44 (0)1865 273813, 273811, 273812
Fax +44 (0)1865 273906

-----Original Message-----
From: Scott Stone <>
To: Nikica Petrinic <>
Cc: linux-eepro100 <>
Date: Sat Sep 26 17:26:46 1998
Subject: Re: Linux kernel 2.0.35 and Intep EEPro 10+/100B/100+

>On Fri, 25 Sep 1998, Nikica Petrinic wrote:
>> Dear Donald,
>> I would appreciate if you could help.
>> We have a Dell PowerEdge 2300 with Intel Ether Express Pro 10+/100B/100+
>> network card (82557 chip) which refuses to work properly with RedHat v5.1.
>> When I booted from the RedHat v5.1 boot floppy in order to
>> download and install RedHat it all worked well (so I thought).
>> I successfully installed everything and rebooted. The network card
>> didn't pick-up. I turned the machine off and on again and the
>> network was there again. I checked if there was a hardware problem
>> with the network card by booting DOS and using Intel's utility
>> software to probe the card. It was reported OK.
>> I upgraded kernel to 2.0.35 (RedHat official updates) and made sure I
>> selected the right driver (make xconfig). Recompiled. Rebooted.
>> No sign of life from the network card. Turned the machine off and
>> on - nothing.
>well, as soon as you recompiled that kernel, you stopped using Redhat's
>official release.  The 'official' way is to install their kernel RPMs and
>then load the eepro100 driver module.  I have a machine here with 2.0.35
>and an eepro100-B card and it works - make sure you're not running
>netatalk, though, since that will, after an hour or so, deactivate the
>card due to too many TX timeouts.
>Scott M. Stone <,>
>               <>
>Head of TurboLinux Development/Systems Administrator
>Pacific HiTech, Inc (USA) / Pacific HiTech, KK (Japan)