[Beowulf] S2466 permanent poweroff, round 2

Joe Landman landman at scalableinformatics.com
Tue Feb 6 11:34:02 PST 2007

David Mathog wrote:
> The Tyan S2466N-4M motherboards bite once again.
> For various reasons I need to upgrade the software on our cluster
> from Mandrake 10.1 to something a bit more modern, so I tried
> Mandriva 2007.  Wiped / and /boot on a test node, did
> a clean install of Mandriva 2007, and pretty much
> everything worked as it should.  Unfortunately
> this resurrected the old problem where "poweroff" leaves the machine
> in a dead state: it doesn't respond to the front panel button
> until the power is unplugged, 20 seconds pass, and the power is
> restored.  This problem was resolved the first time it showed u

Hi Dave:

   We have seen this on lots of Tyan boards in general.  Kind of hard to 
recommend steering clear if you have a room full of them.

> p
> many years ago by upgrading to BIOS 4.06.  There's no newer BIOS,
> so that isn't going to fix it this time.  It isn't a Mandriva 2007
> problem per se because we have another machine (a very old
> Athlon 850 with a Gigabyte motherboard) running that OS and it
> does "poweroff" correctly.  The two machines (poweroff working and
> not working) have exactly the same versions of every RPM package.
> LILO is pretty basic on both of them too:
> image=/boot/vmlinuz
>         label="linux"
>         root=/dev/hda5
>         initrd=/boot/initrd.img
>         append="resume=/dev/hda2"

I seem to remember having to do a noacpi option to make them behave. 
Something about acpi on these boards were horribly broken.  FWIW we have 
seen this with a few late model Opteron (Tyan) boards as well. :(


Joseph Landman, Ph.D
Founder and CEO
Scalable Informatics LLC,
email: landman at scalableinformatics.com
web  : http://www.scalableinformatics.com
phone: +1 734 786 8423
fax  : +1 734 786 8452 or +1 866 888 3112
cell : +1 734 612 4615

More information about the Beowulf mailing list