[Beowulf] S2466 permanent poweroff, round 2

David Mathog mathog at caltech.edu
Tue Feb 6 11:08:41 PST 2007

The Tyan S2466N-4M motherboards bite once again.

For various reasons I need to upgrade the software on our cluster
from Mandrake 10.1 to something a bit more modern, so I tried
Mandriva 2007.  Wiped / and /boot on a test node, did
a clean install of Mandriva 2007, and pretty much
everything worked as it should.  Unfortunately
this resurrected the old problem where "poweroff" leaves the machine
in a dead state: it doesn't respond to the front panel button
until the power is unplugged, 20 seconds pass, and the power is
restored.  This problem was resolved the first time it showed up
many years ago by upgrading to BIOS 4.06.  There's no newer BIOS,
so that isn't going to fix it this time.  It isn't a Mandriva 2007
problem per se because we have another machine (a very old
Athlon 850 with a Gigabyte motherboard) running that OS and it
does "poweroff" correctly.  The two machines (poweroff working and
not working) have exactly the same versions of every RPM package.
LILO is pretty basic on both of them too:


I suppose I could try a vanilla kernel next, but maybe there's some
way to diagnose what state (S5, S0, whatever) the machine is going
to on poweroff, and why?  The documentation for ACPI itself is
humongous, and for the linux implementations essentially absent,
so I don't know what tool to run to find or modify this info. 
Interestingly /proc/acpi/sleep is missing on Mandriva 2007, but that
doesn't seem to hurt anything on the working machine, so maybe that's
(yet another) change in the ACPI interface?


David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech

More information about the Beowulf mailing list