Does my channel bond work

Martin Siegert siegert at
Tue May 7 20:09:37 PDT 2002

On Tue, May 07, 2002 at 07:02:58PM -0700, abhishek Sinha wrote:
> Hi beowulfers
> this again is a old question on channel bonding.But i
> have gone through the archives and doesnt solve my
> purpose.
> here is the problem.
> I am using the RH 7.2 kernel and the channel bonding
> module is definately there. My channel bonding as far
> as testing with ifconfig (as stated in the document) ,
> works
> Now i tried netperf on the system (i am using
> 2*100Mbps cards). This is what netperf gives me
> UDP unidirectional Send test
> Socket size(bytes):131070
> Message size(bytes):1472
> Elapsed Time (sec) : 60
> Throughput (10^6 bits/sec):191.37
> Socket size(bytes):65535
> Message size(bytes):-
> Elapsed Time (sec) : 60
> Throughput (10^6 bits/sec):95.78

Netperf usually tells you what throughput it achieved at the sending node
and what throughput it achieved at the receiving node. Is that what you
are showing here? The two numbers should be the same otherwise you have a
problem (at least the must not be as vastly different as 191Mbps and 96Mbps).
> TCP stream Test
> Recv Socket Size(bytes): 87380
> Send Socket size(bytes) :16384
> Elapsed Time :60
> Throughput (10^6 bits/sec):94.15
> Then i tried Netpipe which gives me saturation level
> of 89.6 Mbps around on the interface bond0.

This is definitely too small for 2 times 100baseT and indicates a problem
with your setup.

Under RedHat setting up channel bonding is usually quite trivial:

first setup the files ifcfg-bond0, ifcfg-eth0, and ifcfg-eth1 in the
/etc/sysconfig/network-script directory.
They should look like the following:

===<sample ifcfg-bond0 file>=========================================

===<sample ifcfg-eth0 file>==========================================

===<sample ifcfg-eth1 file>==========================================

Then put the line

alias bond0 bonding

into /etc/modules.conf.
After that just run

/etc/init.d/network restart

That should get you going.

> The question is , why do i get these two different
> types of data in the UDP table.And what is my real
> bandwith...
> If it is 100Mpbs do i need to upgrade to the 2.4.18
> kernel and then try channel bonding..???

You do not have to upgrade the kernel, but I strongly recommend it.
This has nothing to do with the problems you are seeing (at least I
doubt that very much). However, I never got LAM to work properly before
I upgraded to 2.4.18. If you do not want to do the kernel compile yourself:
RH 7.3 is out and it comes with 2.4.18 ...

> another thing that i noticed was that when i do
> ifconfig bond0 down, eth0 and eth1 are still up .???
> is that right

That's what you get with ifconfig. "/etc/init.d/network stop" will
down all your interfaces.

> Any kind of help/reference to document , slight
> pointer  towards the solution would really be
> appreciated.


is part of the linux-2.4.18 kernel tar ball and should be all you need.
(strangely enough it doesn't seem to be contained in any of the RH 7.2
kernel rpms).

Hope this helps.


Martin Siegert
Academic Computing Services                        phone: (604) 291-4691
Simon Fraser University                            fax:   (604) 291-4242
Burnaby, British Columbia                          email: siegert at
Canada  V5A 1S6

More information about the Beowulf mailing list