Does my channel bond work

abhishek Sinha aby_sinha at
Tue May 7 19:02:58 PDT 2002

Hi beowulfers

this again is a old question on channel bonding.But i
have gone through the archives and doesnt solve my
here is the problem.

I am using the RH 7.2 kernel and the channel bonding
module is definately there. My channel bonding as far
as testing with ifconfig (as stated in the document) ,

Now i tried netperf on the system (i am using
2*100Mbps cards). This is what netperf gives me

UDP unidirectional Send test

Socket size(bytes):131070
Message size(bytes):1472
Elapsed Time (sec) : 60
Throughput (10^6 bits/sec):191.37

Socket size(bytes):65535
Message size(bytes):-
Elapsed Time (sec) : 60
Throughput (10^6 bits/sec):95.78

TCP stream Test
Recv Socket Size(bytes): 87380
Send Socket size(bytes) :16384
Elapsed Time :60
Throughput (10^6 bits/sec):94.15

Then i tried Netpipe which gives me saturation level
of 89.6 Mbps around on the interface bond0.

The question is , why do i get these two different
types of data in the UDP table.And what is my real

If it is 100Mpbs do i need to upgrade to the 2.4.18
kernel and then try channel bonding..???

another thing that i noticed was that when i do
ifconfig bond0 down, eth0 and eth1 are still up .???
is that right

Any kind of help/reference to document , slight
pointer  towards the solution would really be


Do You Yahoo!?
Yahoo! Health - your guide to health and wellness

More information about the Beowulf mailing list