Intel ethernet adapter + driver issues

Derek Richardson derek.richardson at
Thu Aug 22 07:28:53 PDT 2002

Is there anyone out there who has worked w/ building an extra driver
into the initrd images used for a kickstart install ( which are
radically different from a normal boot initrd )? Basically, I am trying
to do a kickstart install of a machine ( using the Intel PXE boot stuff
and TFTP ), but the machine I am trying to install has a very new Intel
motherboard, w/ dual onboard Gigabit NICs.  This adapter requires the
latest Intel e1000 driver, so I have to build it into the initrd ( the
modules are contained w/in a gzipped cpio archive w/in the initrd image
) for the machine to be able to see the network after the initial PXE
boot.  I have built the kernel module for the appropriate kernel level (
tried both 2.4.18-3 and -5 from RedHat, am working on 2.4.2-2 right now,
but there appear to be some issues w/ getting that to compile ), and
then added the Vendor and Device IDs into the pcitable file which maps
the driver to the IDs, which is what all the resources I've been able to
find say is all you need to do.  But it still looks as if the module
doesn't load, and I don't have a way to do any creative troubleshooting,
since there are no floppies or CD drives on this machine, the only
avenue for getting an OS on this machine is via a network install.  Oh,
BTW, if it helps, the NIC is a Intel 82546BE, Device ID 1010.  Any and
all help is very welcome!
Derek R.
Jr. Linux Administrator
Office 713-781-4000
Cell 713-817-1197
(1) Avoid fried meats which angry up the blood.
(2) If your stomach antagonizes you, pacify it with cool thoughts.
(3) Keep the juices flowing by jangling around gently as you move.
(4) Go very lightly on the vices, such as carrying on in society, as
	the social ramble ain't restful.
(5) Avoid running at all times.
(6) Don't look back, something might be gaining on you.
		-- S. Paige, c. 1951

More information about the Beowulf mailing list