need passwd to use mpirun

Joseph Mack mack.joseph at
Wed Oct 31 06:04:40 PST 2001

Daniel Kidger wrote:
> >From: Joseph Mack [mailto:mack.joseph at]
> >I have run ssh-agent/ssh-add and can login to the slaves from
> >the master without a passwd/passphrase
> >
> >I can run tstmachines -v successfully
> >
> >On all machines, I have serv_p4 -o -p 1234 running
> >in the environment
> >
> >problem: from the same xterm as I run the above tests,
> >when I run
> >
> >#mpirun -np somenumber ./mpi_testprogram
> >
> >I'm asked for the passwd of the slave machines.
> hmm. Dont run as root.
> It will may well work as a mortal user.


now it asks me for the user's passwd.

If I kill serv_p4, then mpirun executes the program on all machines
without prompting me for a passwd. 

It would appear that ssh and serv_p4 are incompatible on my setup.


Joseph Mack PhD, Senior Systems Engineer, Lockheed Martin
contractor to the National Environmental Supercomputer Center, 
mailto:mack.joseph at ph# 919-541-0007, RTP, NC, USA

More information about the Beowulf mailing list