Scyld module configuration

Ben DeLong ben.delong at
Mon Jul 16 06:51:43 PDT 2001


Thanks for the response.  I gave this a try this morning and it caused 
the slave nodes to not recognize the network card during phase 2 boot. 
 It looks like there is a problem loading the 3c59x driver during phase 
2.  I applied this change to phase 1 boot as well with the same results. 
 When I put the old phase 1 kernel back I got the error during phase 2. 
 The specific error that I get is:

boot: failed to load dependancy for module "3c59x"

Finally if I take the modarg line back out, the slaves boot fine in 10Mb 

I am running version 27BZ-7 of Scyld Beowulf.  The network card that I 
am using is 3cSOHO100-TX.  On a side note I believe that the speed issue 
is only with the 2.2 kernel.  This weekend I install one of these cards 
into a RedHat 7.1 (kernel 2.4.2) machine and it was automatically 
detected at 100Mb.


Sean Dilda wrote:

>On Fri, 13 Jul 2001, Ben DeLong wrote:
>>A couple of weeks ago I posted a question regarding a specific 3Com 
>>network card that wouldn't detect 100Mb/sec with the 2.2.x linux kernel 
>>(Mandrake 7.2) and instead only ran at 10Mb/sec.  I was able to fix the 
>>problem by passing an option to the 3c59x module when it was loaded. 
>> Specifically I added the line "options eth0 options=8,8" to the 
>>module.conf file.
>>Yesterday I got around to installing Scyld on our 4 node cluster and 
>>bumped into the same problem - all the cards were running at 10Mb after 
>>install.  On the head node the problem was easy enough to fix by adding 
>>the options line to the conf.modules file on the head.  My question is 
>>how do I pass this parameter on the slave nodes?  I have looked through 
>>all the documentation I have and I can't find an answer.
>In the /etc/beowulf/config.boot file you can add the line:
>modarg 3c59x options=8,8
>Then remake your phase1 and phase2 images and it should do what you
>want.  This should be documented in the reference guide, available at
>By the way, what version of our software are you running?  I ran into a
>problem with a 3com card not detecing 100M in our preview release, but
>the updated drivers in the 27bz-7 release worked without a problem.

More information about the Beowulf mailing list