[vortex-bug] Need help with the 3c59x driver with kernel 2.4.0

Amit Chaudhary amitc@brocade.com
Thu, 1 Feb 2001 18:18:31 -0800


I have a notebook, Toshiba Tecra 8100 on a docking station with the 3com ethernet driver. The problem is that eth0 initializes and I can ping my own computer, but nothing outside including the gateway is accessible. The error is destination ins unreachable.

ifconfig shows +ve values for both Tx and Rx packets 
vortex-diag identifies it to be a 3c5909C TX Tornado.
The kernel I am using is 2.4.0, the driver file 3x59x.c has LK 1.11 has the last comment\modification.

I went through the vortex mailing list and tried a variety of stuff. Changing the timeout variable from 4000 to 50000 or 4000000 does not help, neither do the phyx changes as suggsted by Donald. I tried setting debug=2 and received the messages
PCI: IRQ conflict with device xxxx

MII transceiver not found.

Finally I tried changing the PCI card from auto-negogiation to PCIC, but that did not help either. The bios is set to identify devices.

Any advice ideas are welcome? If you believe the problem is with the network settings, I can send those too. Though I know them to be ok and also the same laptop came with win98 which boots fine.

Thanks and Regards