LNE100TX - tulip works, almost

Alexander Perry arperry@cts.com
Mon Dec 21 03:50:50 1998

I've compiled both the 'release' and the '2.0.34' test
versions of tulip.c and both give me the same problem.
When I "insmod", I get told that the module was compiled
for 2.0.33 when I am running a 2.0.34 kernel.  This is
odd because the kernel source is 2.0.34 .. and I've checked
version.h and its contents match my expectations.  
I'm running Debian's Hamm (the current release).

==> Anybody any ideas on what I've forgotten ?

If I "insmod -f" and ignore the nasty comment, it works
fine.  However, I don't think I can do a "-f" in the
"modules" listing, so I have to bring it in manually
every time.  Fine for testing, but it's a pain.

I guess I haven't figured out the correct "options", 
because I'm trying to use it to a 10baseT hub.  A few
seconds after I do the "ifstart", I get a console
message telling me that the transmitter stopped running.
I'm _assuming_ this is when the board realizes that it
is connected to 10 (rather than 100) speed media, and
reconfigures itself relatively quietly to that mode.

==> I assume I need to use "options=12" to avoid this?

Finally, it would be very convenient if you provided
a nice little script to "grep" the source to find the
compile command, then execute the command directly.
Not that it's hard to write, of course.

I am using two different LinkSys cards in two
machines, and I tried to get the company's diagnostics
that run under DOS to verify that the cards work.
Their software failed to make the cards communicate,
so I called them up for assistance and they said that
they don't provide phone support.

In mild desperation, I tried "tulip-diag" but it failed
to detect any network cards in the machine, even though
the board is clearly in the PCI listing.  Using the "-p"
option worked.

==> Is this just because the "diag" chip listing is old?

It seems to me that it would be much simpler if...
- When searching the PCI list to find a tulip card,
- For every "network card" that is not recognized,
- Report it as a list with a huge card number.
- When using the option to specify which board to diag,
- Recognize these numbers when choosing a board.

The unhappy user would then type
# tulip-diag
No devices match known Tulip characteristics.
Use -101 to examine the unknown "LNE100TX" device
No other devices have sufficient features to be possible.
# tulip-diag -101

Thank you for your attention, Alex.