[scyld-users] Python upgrade breaks admin tools

Donald Becker becker at scyld.com
Tue Jan 24 14:00:49 PST 2006

On Tue, 24 Jan 2006, Gardner Pomper wrote:

> I have Scyld version 29, and when I upgraded to python 2.4.2, all the 
> admin scripts stopped working, so now I can't check my network card, 
> etc. Anyone have any idea how to fix this? If I can't fix it, then how 
> about a suggestion on how to avoid the problem after I re-install?

Which admin scripts?

The only current Scyld-created tool that depends on Python is the 
Beostatus GUI.  There are few old programs e.g. /usr/sbin/config2pxe that 
still use Python, but we avoid writing new ones in Perl/Python/Ruby for 
exactly this reason.

Donald Becker				becker at scyld.com
Scyld Software	 			Scyld Beowulf cluster systems
914 Bay Ridge Road, Suite 220		www.scyld.com
Annapolis MD 21403			410-990-9993

More information about the Scyld-users mailing list