[Beowulf] Help with HPL Makefile

snj78 at comcast.net snj78 at comcast.net
Wed Apr 11 21:02:03 PDT 2007

Thanks for your replies everyone.  I feel like I am understanding things a little better.  One thing that I realized but not sure if this makes a difference is that I have installed an openmpi package and an mpich package so could that cause problems using the mpicc compiler and linking the different packages/libraries?

I have rebuilt my make file and something interesting that I have noticed is that no matter what I change I still get the same error.  I am always getting the following error:

Makefile:47:  Make.inc: No such file or directory
*** No rule to make target 'Make.inc'. Stop

I use the following command in my top directory, which is /hpl:

make arch=Beowulf

while my makefile is Make.Beowulf.  I am still at a loss at can't figure out what to do next so I really the help you guys have given me, even though this may seem trivial.

The make file and error log follow:


SHELL = /bin/sh
CD = cd
CP = cp
LN_S = ln -s
MKDIR = mkdir
RM = /bin/rm -f
TOUCH = touch
ARCH = Linux_x86_64
# - HPL Directory Structure / HPL library ------------------------------
TOPdir = $(HOME)/hpl
INCdir = $(TOPdir)/include
BINdir = $(TOPdir)/bin/$(ARCH)
LIBdir = $(TOPdir)/lib/$(ARCH)
HPLlib = $(LIBdir)/libhpl.a 
# - Message Passing library (MPI) --------------------------------------
MPdir = /usr
MPinc =-I$(MPdir)/include/openmpi
MPlib = $(MPdir)/lib64/openmpi/libmpi.so
# - Linear Algebra library (BLAS or VSIPL) -----------------------------
LAdir = /usr/lib64
LAinc =-I$(MPdir)/include
LAlib = $(LAdir)/libblas.so.3 $(LAdir)/atlas/libblas.so.3
HPL_INCLUDES = -I$(INCdir) -I$(INCdir)/$(ARCH) $(LAinc) $(MPinc)
HPL_LIBS = $(HPLlib) $(LAlib) $(MPlib)
# ----------------------------------------------------------------------
# - Compilers / linkers - Optimization flags ---------------------------
CC = mpicc
CCFLAGS = $(HPL_DEFS) -pipe -O3 -funroll-loops
LINKER = mpicc
RANLIB = echo

Error File ( Condensed to show the last portion with the error code )

make -f Make.top refresh_tst arch=Beowulf
make[1]: Entering directory `/hpl'
cp makes/Make.matgen testing/matgen/Beowulf/Makefile
cp makes/Make.timer testing/timer/Beowulf/Makefile
cp makes/Make.pmatgen testing/pmatgen/Beowulf/Makefile
cp makes/Make.ptimer testing/ptimer/Beowulf/Makefile
cp makes/Make.ptest testing/ptest/Beowulf/Makefile
make[1]: Leaving directory `/hpl'
make -f Make.top build_src arch=Beowulf
make[1]: Entering directory `/hpl'
( cd src/auxil/Beowulf; make )
make[2]: Entering directory `/hpl/src/auxil/Beowulf'
Makefile:47: Make.inc: No such file or directory
make[2]: *** No rule to make target `Make.inc'. Stop.
make[2]: Leaving directory `/hpl/src/auxil/Beowulf'
make[1]: *** [build_src] Error 2
make[1]: Leaving directory `/hpl'
make: *** [build] Error 2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20070412/fa954284/attachment.html>

More information about the Beowulf mailing list