"mmap failed"---help

Sean Dilda agrajag at scyld.com
Sat Aug 25 10:26:04 PDT 2001

On Sat, 25 Aug 2001, pramod ps wrote:

> hi there,
>   i tried to impliment the beowulf cluster using scyld
> cd in my college. i've instaled the server & booted
> the clients using floppy disks.
> then i partitioned the hard disk of the client
> remotely by giving commands, beofdisk -d & beofdisk
> -w.
>   then i restart the machine , edit the fstab &tried
> to execute a program. but the client showed an error
> message as , " mmap failed".

Can you give me more details about where exactly you saw the "mmap
failed" error message

> when the program is given to execute in the server ,
> it succesfully executed & showed the result. i'am
> using only one client to try this.
>   its possible to create & write the partition table
> to client remotely. but when we tried to write the
> boot record & boot the system from hard disk , it
> showed that the there is no bootable partition. 
> i think the problem is that of mounting the client
> hard disk to the server.

The master node never mounts the slave nodes harddrives.

NOTE: I assume by 'server' you mean master node, and by 'client' you
mean slave node or compute node.. please let me know if I am wrong in
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20010825/f89880af/attachment.sig>

More information about the Beowulf mailing list