(Scyld Beowulf)All nodes up, but processes run on only one node?

Sean Dilda agrajag at scyld.com
Fri Aug 10 07:48:59 PDT 2001


On Fri, 10 Aug 2001, Eric T. Miller wrote:

> 
> 
> Admitted newbie, two quick questions.  Cluster consists of 9 AMD K62/350's
> running the demo version of Scyld
> 
> 
> 1. When I run the Mandelbrot renderer, only one of the nodes seems to be
> processing a job, by the output of the BeoStatus.  The processor % and
> network bandwidth % on the other two slaves remains unchanged during the
> process?  If I run the process with only one node attached (regardless which
> one), it will run fine on that node.  When I connect two or more slaves, it
> still only registers using resources on one node (usually the last node I
> brought up)?

Try doing:
NP=9 mpi-mandel

That should tell MPI to use 9 processors (you need to have the number be
the number of slave processors [not nodes] you want to use, plus 1 for
the master).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
Url : http://www.scyld.com/pipermail/beowulf/attachments/20010810/152fc10e/attachment.bin


More information about the Beowulf mailing list