running MPI, and login in locally into slave nodes

Sean Dilda agrajag at
Fri Aug 3 15:45:00 PDT 2001

On Fri, 03 Aug 2001, german kogan wrote:

> On Fri, 3 Aug 2001, Sean Dilda wrote:
> > > But what if I need to lets say change a specific file on a particular
> > > slave node? Also I ran a command bpsh 0 ls -la, I have one slave node up,
> > > and I got back the exact same list of files as in my home directory on the
> > > master node. Is this supposed to be like this? Are the slave node exact
> > > copies of the master node? Also my ping is working but I can't telnet or
> > > ssh to the slave node.
> >
> > That is expected because home directories are nfs mounted on the slave
> > nodes.  If you do that in any directory that isn't in /home, the results
> > will not match.
> So how would you traverse the directory hierarchy on the slave node. I
> tried doing "bpsh 0 cd .." but it did not work, it said "cd command not
> found"

When you bpsh to a slave node, it will automatically put you in the
same directory on the slave node that you are in on the master node.  If
you're in a directory that doesn't exist on the slave node, it will just
change your directory to be / on the slave node.

If you're trying to just do ls, you can also try telling ls which
directory to looks at, ie:
bpsh 0 ls -l /usr
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <>

More information about the Beowulf mailing list