Scyld, beoboot-install

Jon Tegner tegner at
Thu Oct 26 00:37:30 PDT 2000

It has turned out that in our case the problem is a result of the fact
that the nodes are "not ready" when we try to do the beoboot-install. It
takes about four minutes for the nodes to become changerooted to
/rootfs, and after that we have no problem with beoboot-install. So by
just waiting four minutes everything is OK.

My question now is why does it take so long time? Could it be a hardware
issue (apart from ata/100 disks - but I believed that issue was solved,
see previous post on this list) our hardware is fairly standard? Is
there a way to check this (log-files somewhere)?



> > having problem. Try to follow the steps in Installation Guide:
> > 1. beofdisk -d
> > 2. beofdisk -w
> > 3. beoboot-install -a /dev/hde
> >
> > At the step three I get the following:
> > Creating boot images...
> > Building phase 1 file system image in /tmp/beoboot.2056...
> > ram disk image size (uncompressed): 1452K
> > compressing...done
> > Kernel image is:    "/tmp/.beoboot-install.2055".
> > Initial ramdisk is: "/tmp/.beoboot-install.2055.initrd".
> > Installing beoboot on partition 1 of /dev/hde.
> > mke2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
> > ext2fs_check_if_mount: No such file or directory while determining
> > whether /dev/hde1 is mounted.
> > can't create lock file /etc/mtab~2108: No such file or directory
> > (use -n flag to override)Failed to mount boot partition.
> basically / is read only and /etc is missing
> what i did was using bpsh to make a ext2 partition
> on /etc with /dev/ram3 that worked for me on /dev/hda
> i don't know if it will work on hde
> >
> > Any hints of what I'm doing wrong?
> > Thanks, /jon
> >

More information about the Beowulf mailing list