Problem while loading beowulf modules.

Jag agrajag at linuxpower.org
Sun Dec 17 08:26:34 PST 2000


On Sun, 17 Dec 2000, Cyrus wrote:

> hi there,
> i installed the beowulf packages on my RH6.2 system. 
> [viz.. bproc* and beo*]
> All the configurations are fine, but when i try to
> start the beowulf daemon, i get the error from
> "modprobe" that it can't find "bproc" module.
> I've even tried giving the path in /etc/conf.modules
> it goes like this
> 
> path[bproc]=/lib/modules/2.2.16-21.beo/misc
> 
> but still it gives me the same error, then i again
> edited the modules.dep and mentioned the bproc.o in by
> 
> /lib/modules/2.2.16-21.beo/misc/bproc.o:
> but still it gives me the same error..
> can you please help me with this, i mean i can't seem
> to find any other possible way ...

What does 'uname -r' give you?  If it doesn't say '2.2.16-21.beo', then
you need modify your lilo.conf to make sure you boot the 2.2.16-21.beo
kernel (see man lilo.conf for more info), then run /sbin/lilo to make
sure your changes take affect, then reboot.

Also, make sure /lib/modules/2.2.16-21.beo/misc/bproc.o exists, and make
sure that after you edit your conf.modules file that you run depmod -a.

(This assumes you're using a single processor box, if its dual
processor, all mentions of 2.2.16-21.beo need to be replaced with
2.2.16-21.beosmp)


Jag
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
Url : http://www.scyld.com/pipermail/beowulf/attachments/20001217/23bb9957/attachment.bin


More information about the Beowulf mailing list