[vortex] 3cSOHO100-Tx Speed Problem

Mark Lubratt mark.lubratt@indeq.com
Wed, 29 Nov 2000 10:25:01 -0600

I just bought a 3cSOHO100-Tx card and I'm installing it on my Linux box at
home.  The Linux system is a ALR 6x6 Revolution with 128MB RAM and 6 PPro
200MHz.  It is running RH6.0 with the SMP kernel (2.2.5-15).  My network
uses a LinkSys 10/100 dual speed 5-port hub.  The NIC is not in a PCI/ISA
shared slot.

While the chip seems to be a 3c76x, I downloaded the latest 3c59x driver
with pci-scan and other stuff from the Scyld website. I have compiled the
drivers as modules and placed the modules in initrd so that they get loaded
out of the boot RAM drive to allow time for negotiation.

When I power up the computer, the link comes up at 100Mbs (as indicated on
the status lights both on the hub and the NIC).  It stays that way through
driver loading until the network is brought up.  At that point, the system
downshifts to 10Mbs.

I used vortex-diag and that said the available media types were 100baseTx
and 10baseT, but that the card was using 10baseT.  I tried usind
'vortex-diag -A 100baseTx' to no avail.  I also used 'mii-diag eth0 -A
100baseTx'.  Both didn't seem to work.  I've also tried a different network
cable.  Nothing seems to work.

Does anybody have any suggestions?  I've looked through the vortex archives
and the most promising thread ended up being a bad cable.