[vortex-bug] 3COM 3c575 3CCFE575BT PCMCIA w/2.4.x

Andrew Morton akpm@zip.com.au
Tue, 14 Aug 2001 12:24:41 -0700

Chris Schanzle wrote:
> Been trying to get a 3CCFE575BT Cyclone CardBus PCMCIA card going with
>    2.4.x for a while in an oldish Gateway Solo 366MHz laptop. I'm told
> it worked under kernel 2.2.x, and it works fine under Win98. My guess is
> the 3c59x driver is not reading the  EPROM properly. Older IBM Ethernet
> II card (NE2000 clone) works fine, and I have a Adaptec SlimSCSI
> APA-1460A working fairly well, so I think the PCMCIA bridge works.
> Baseline distribution is RH 7.1 with updates. Tried several kernels,
> including redhat's 2.4.3-12, 2.4.3-15 (for reiserfs umount fix), and
> hand-building 2.4.7-ac9 and 2.4.8-ac3.
> Note the "Failed to allocate resource 0 (1000-fff)" line - the second
> part of the region is a *smaller* number, and the MAC address is
> obviously incorrect.

Yes, presumably it read 0xffffffff for the resource length, and then
tried to reserve the range 0x1000 to 0x1000+0xffffffff.

Something wrong with the socket power management, I suspect.

I'll have a look at the code, not really sure why this is happening
right now.