[tulip] Linksys 10/100 PCI card lockup problems

Kelly Shutt tcatut at mail.utexas.edu
Sat Jun 19 13:17:35 PDT 2004

One more time.... stupid email client sent through the wrong acount... 
this one should go through.

I have one of the Linksys FastEthernet network cards that has locking 
issues with the tulip driver.  It will periodically lockup when I'm 
doing things over the network or internet.  I have a slackware 9.1 
machine with two NICs.  The 3com nic goes to my cable modem and it never 
has problems, the linksys nic goes to my local network and it will 
lockup at random points.  Sometimes I will be doing nothing and when I 
go to use my connection it will be locked up, other times I will be 
running high speed transfers through the local network and it will lock 
up in the middle.  I've already done a ton of trouble shooting as it has 
been on going for the last 2 years now.  The 2.4.21 linux kernel had 
some changes in the tulip driver that seemed to fix my issues, but I 
recently updated to 2.6.6 and the problem is worse than ever now.  My 
nic is locking up like every 5 minutes now.  I've tried switching back 
to the old 2.4.21 kernel but since I had to update my module tools and 
everything that doesn't seem to work at all now either.

This issue seems to be very intermittent.  When I am having problems the 
nic will lock often, but other times it will work for several days with 
any problems.  The nic will lock and I have no local network access but 
the rest of the machine will work fine and the 3com nic will be fine.  
As I said, I've already done a ton of troubleshooting on this, I've 
tried several versions of tulip and forcing settings on the nic.  The 
lockup symptoms are weird, it looks like the buffers are getting stuck 
in a standby mode or something like that.  It doesn't actually stop 
working all together, it just stops transmitting data for a short 
period.  Usually it'll last about 5 minutes, and if I just leave it 
alone it will unlock on it's own.

I seem to remember reading somewhere that it's some kind of IO lockup 
but I don't remember half the stuff I read about this problem, so I 
could be wrong.  I also remember seeing that it could be a problem with 
samba causing the lockup as most of my client machines run windows.  If 
I run tulip with debug on the most I"ve been able to get out of it is an 
IO wait error, it looks like the IO stuff is just getting stuck in wait 
state for some reason.

Anyways, I'd like to get my issue sorted out finally if possible.  Does 
anyone have any good ideas that I may not have thought of?  I'm not at 
home right now, but I'm going to run tulip-diag and run the driver in 
debug mode when I get home.  I'll make another posting later with some 
errors if possible.  Any help would be greatly appreciated, I'm pretty 
comfortable with my system but troubleshooting weird things like this 
can get me sometimes.

Kelly Shutt

More information about the tulip mailing list