[tulip] Solved TULIP seg fault with Kernel 2.4.20-8

Manish Kurup manish.kurup at verizon.net
Thu Aug 19 21:33:14 PDT 2004

Further investigation into he driver code revealed the following problem 

the read_eeprom(...) function (Within tulip_probe1)was called before 
setting up dev->base_addr to point to ioaddr.

Moved the following lines of code before the EEPROM read, made the 
problem go away ..

#ifdef USE_IO_OPS
        /* We do a request_region() to register /proc/ioports info. */
        request_region(ioaddr, pci_id_tbl[chip_idx].io_size, dev->name);
        dev->base_addr = ioaddr;
        dev->irq = irq;
The dev->irq is not really needed here, I guess it can stay where it 
usually was.

U need to move the request region too .. in case Ur using IO mapped mode 
... For memory mapped mode, it works just fine .. I have tried it with 
both ...

Just in case someone else is having the same problem that I was ... :) !!

Thanks for the driver ... It's been real helpful !!!


More information about the tulip mailing list