[tulip] Tulip and PowerPC endian issue?

Jim Rowe rowejames@acmsystems.com
Fri Jan 31 15:30:08 2003

Hi Donald,

> Has anyone with a PPC tried to the driver with a message level of 15?

I just tried this on my PPC with 'insmod tulip.o debug=15'. 

Here is the log:

root@eth0:/usr/src/netdrivers# dmesg
root@eth0:/usr/src/netdrivers# lsmod
Module                  Size  Used by
tulip                  39392   0  (unused)
pci-scan                3664   1  [tulip]
ds                      8688   0  (unused)
yenta_socket           11792   2 
pcmcia_core            42656   0  [ds yenta_socket]
root@eth0:/usr/src/netdrivers# rmmod tulip
root@eth0:/usr/src/netdrivers# insmod tulip.o debug=15
root@eth0:/usr/src/netdrivers# dmesg
tulip.c:v0.95f 11/17/2002  Written by Donald Becker <becker@scyld.com>
eth1: ADMtek Centaur-C rev 17 at 0xc902f000, 00:10:7A:69:F0:79, IRQ 30.
eth1:  MII transceiver #1 config 1100 status 7849 advertising 05e1.

Jim Rowe
Advanced CounterMeasure Systems
Email: jrowe@acmsystems.com