[tulip] problems with accton en2242

Donald Becker becker@scyld.com
Wed Jan 23 12:51:01 2002

On Tue, 22 Jan 2002, PAZINCZAR Peter wrote:

> I have a problem with the card called Accton EN2242 MiniPCI (recognized as
> ADMtek comet (rev 17) by tulip).
> I'm using the kernel v. 2.4.17 (debian/linux). The notebook is a Gericom
> stuff. First of all, on boot time the card got an IRQ 0. I`ve solved this
> problem setting the IRQ by setpci -s 00:05.0 interrupt_line=0a (03 also
> tried), `cos there were no possibility to set it in the PCI BIOS.

You haven't solved the problem.  You still are not getting interrupts
from the card.

> After
> reboot it worked with the new IRQ. The kernels module passed, eth0 seemed
> to work fine. After this came some problems.
> The output of tulip-diag is:
> Interrupt sources are pending!  CSR5 is fc07c017.
>  Tx done indication.
>  Tx complete indication.
>  Tx out of buffers indication.
>  Link passed indication.

Yup, the chip is raising an interrupt, but no one is listening.

> If i send a packet over eth0 (ifconfig output seems to be normal), i get
> the following:
> Jan 21 21:54:19 xxx kernel: NETDEV WATCHDOG: eth0: transmit timed out
> Jan 21 21:54:19 xxx kernel: eth0: Transmit timed out, status fc67c017,
> CSR12 00000000, resetting...

...And this confirms it.

This problem is no a Tulip driver issue.  The problem is the interrupt
mapping.  You should ask about it on the kernel mailing list.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993