[tulip] Help: Accton EN2242 in 1st Supersonic M6T notebook

Holger@Jakobs.com Holger@Jakobs.com
Wed Jan 9 12:27:01 2002

Hi everybody,

I have been searching for a way of using the builtin 10/100 Mbit/s network 
adapter, obviously an Accton EN2242 in my 1st Supersonic M6T notebook by 

After finding out that there is a "tulip" driver that might be able to make use of it, 
I tried to make changes to the module, file tulip_core.c and also found hints 
that some driver called tulip.c should be changed. None of them worked.

Some nice people tried to help by telling me to change settings in the BIOS, 
but unfortunately the BIOS in the machine does not have these "advanced" 
settings like PnP-OS or the like.

Trying to insert a successfully compiled pci-scan.o module gives lots of 
unresolved symbols like "pci_write_config_byte", "pci_find_class", "kmalloc" 
and the like, so working according to 
{HYPERLINK "mailto:tulip@scyld.com?Subject=Re:%20[tulip]%20Problems%20compiling%20the%20tulip%20driver&In-Reply-To=<Pine.LNX.4.30.0101081317550.17825-100000@anime.net"}http://www.scyld.com/network/updates.html did not work either.

Is there any hope? Next problem (not in this mailing list though) would be the 
"winmodem", for which I managed to compile and load the module, the modem 
even reacts with OK when I send an AT command, but it won't dial.


Holger Jakobs, holger@jakobs.com
www.jakobs.com, Holger@Jakobs.com