[tulip] DFE-570TX & Mandrake

Ben Greear greearb@candelatech.com
Tue, 25 Sep 2001 12:51:20 -0700

The kernel driver was busted untill about 2.4.8.
Try a kernel after that and I think you'll have better


Ian Marsh wrote:
> I've been trying to setup a 4-port DLink DFE-570TX with Mandrake Linux 8.0 (that's what I had kicking around).
> I've tried using every version of tulip for 0.92 to 1.1.8, but nothing seems to work.  The card seems to configure properly, and each interface can ping itself, but nothing works past that.  The interface cannot ping anything on the network, or be pinged.  Running ifconfig shows all RX packets as dropped, and no TX packets at all.
> If I run tulip-diag, is says:
> Index #1:  Found a Digital DS21143 Tulip adapter at 0xb000.
> Port selection is MII, half-duplex.
> The RX process state is 'Suspended -- no RX buffers'.
> The TX process state is 'Idle'.
> The transmit threshold is 128.
> Interrupt sources are pending!  CSR5 is f06980c4.
> Tx out of buffers indication.
> Rx Done indication.
> Receiver out of buffers indication.
> The NWay status register is 000000c6.
> Internal autonegotiation state is 'Autonegatiation disabled'.
> Also, if I bring up a second eth(x) interface, the whole system stops responding.
> If anyone could shed some light on how to solve this, it would be greatly appreciated!
> Thanks,
> Ian Marsh
> Technical Assistant
> Onoway High School
> _______________________________________________
> tulip mailing list, tulip@scyld.com
> To change to digest mode or unsubscribe visit
> http://www.scyld.com/mailman/listinfo/tulip

Ben Greear <greearb@candelatech.com>          <Ben_Greear@excite.com>
President of Candela Technologies Inc      http://www.candelatech.com
ScryMUD:  http://scry.wanfear.com     http://scry.wanfear.com/~greear