[tulip] Can't get Accton EN1207 to work in 100MBit

Marcus Blomenkamp MBlomenkamp@t-online.de
Wed, 12 Sep 2001 14:48:06 +0200

This probably has been asked a million times before, perhaps someone will 
help me (newbie) anyway. I've got this fairly old NIC (bought around 1998?) 
and I can get it to work in 10baseT-FDX and Coax (10base2?) but not in 

cat /proc/pci says:

  Bus  0, device  13, function  0:
    Ethernet controller: Digital Equipment Corporation DECchip 21140 
[FasterNet] (rev 17).
      IRQ 12.
      Master Capable.  Latency=32.
      I/O at 0xe800 [0xe87f].
      Non-prefetchable 32 bit memory at 0xdd001000 [0xdd00107f].

I've tried these module options with no effort:
options tulip options=0x33 # seen on a website
options tulip options=[0..19]  # tried every

The MII diagnosis programs (mii-tool + tulip-diag) say, the card has no MII 
module and that the eeprom is an old style. On the rear of the card I have 
one coax and two tp-connectors named 10M and 100M. For diagnosis there are 
four LEDs (Traffic, Coax, Link OK, 100M). As peer I have a 3c59x through 
crossover-cable (also tried a switch yesterday). If I set the card options to 
what should be 100*, the 100M-LED lights. Then if I connect the cable to the 
100M-connector, the LinkOK-LED stays off (same on peer). If I connect the 
cable to the 10M-port, the LinkOK-LED goes on with the 100M-LED still 
lighting. However the peer says we're still in 10er mode. Needless to say 
that transmission doesn't work :-(

So what can be further done to get a positive result? I've made pictures of 
the card which I could post/send so someone perhaps recognizes the card.

Sorry for the length of this posting...