[tulip] 7.0 and or 7.1 bug

Ben Greear greearb@candelatech.com
Tue, 08 May 2001 22:51:15 -0700

> risc wrote:
> Hello Linux gurus,
> I am very new in the Linux world and I'm seeking some expert assistance.
> I've read somewhere that RedHat 7.0 has a flawed configuration
> with the default install. The work-around provided was to install
> netdrivers-rh70.i386.rpm which I did. rpm -qa shows it as netdriver-2.1-2.
> I just would like to mention that I have install 7.1 instead of 7.0 and I'm not sure if that makes any difference.

That makes a big difference.  Scyld's drivers have not (yet??) been
ported to Linux 2.4, which is what RH 7.1 installs.

If you've already forced the install of the RH 7.0 scyld drivers, then
you will probably need to re-install the kernel RPM for 7.1, but I haven't
actually tried that yet...  You could also download the 2.4.4 kernel
from www.kernel.org and compile/install it...

Basically, you are stuck with the drivers in the 2.4 series, which
is not necessarily bad:  They are maintained and seem as functional
as Scyld's for the most part...

> Continuing, I proceed to compile tulip.c which is the driver I originally use for my Linksys 10/100 PCI net card. However, as
> it is being compiled, it spewed the following messages which supposedly have been cured by installing the *rh70*i386.rpm as mentioned above:
> tulip.c: In function `tulip_open':
> tulip.c:1437: structure has no member named `tbusy'
> tulip.c:1438: structure has no member named `start'
> ...

Have you tried just using the tulip driver that comes with RH 7.1?

Good luck!


Ben Greear <greearb@candelatech.com>          <Ben_Greear@excite.com>
President of Candela Technologies Inc      http://www.candelatech.com
ScryMUD:  http://scry.wanfear.com     http://scry.wanfear.com/~greear