[tulip] EEPROM fixup on PPC

Dag Nygren dag@newtech.fi
Thu, 15 Mar 2001 10:26:38 +0200


just ran into an "interesting" tulip
implementation on a PPC board I
am porting Linux 2.4.2 to here:
- They had left out the EEPROM
  on a 21143 system.....

Ok, no problem, there is a fix in the
driver  for that.

But there was some things that did not work
on a PPC, here they are if you want to fix the
general parts (I can get you a diff if you are interested
enough :-) )

- Firstly the driver refused to load any media table
  when not finding any EEPROM. Easily fixed by
  removing one return after the warning for no EEPROM
- Secondly: The EEPROM data in eeprom_fixup is defined
  as words and later interpreted as bytes. The PPC byteordering
  will make these go haywire.Esily solved by changing the eeprom_fixup
  data type to unsigned chars.
  (Is there a good reason for having them as words, Donald ?)
- Thirdly: The docs for doing your own eeprom_fixup table will not
   really work for a 21143. But defing a media table with entries of
   type 2 and 4 worked out fairly well.
- Fourth: The MAC address had to be obtained from a completely
  other place on the board. This is not really a general  (your) problem and
  will have to be hacked especially for my board here.


Dag Nygren                               email: dag@newtech.fi
Oy NewTech Ab                            phone: +358 9 8024910
Trasktorpet 3                              fax: +358 9 8024916
02360 ESBO                                 GSM: 0400-426312