[tulip] problems with dec-chip cards

Frank Lingott f.lingott@cfn.de
Wed, 7 Mar 2001 23:02:37 +0100


 
Hi,

i have a little problem with my server.
It has 2 netcards,

eth0 -> Cogent EM110 / DC21140
eth1 -> DEC DE450TA / DC21041

eth0 is connected to my internal network,
eth1 is connected to my dialup-server via crossover link.

Everything works well with the old Installation(kernel 2.0.35/suse 5.3)
Driver is 
tulip.c:v0.89H 5/23/98 becker@cesdis.gsfc.nasa.gov
Now ive installed a new system(suse6.4/kernel2.2.14) on the
second disk.
I configured the network in the same way like my old system,
but eth1 does not work.
I can not reach the dialup server from the server and i cannot
reach the server from the dialup server.
Strange,its the same host !

Is it the driver or the kernel ?

and here some output from the old installation :

/etc/conf.modules

# Aliases - specify your hardware

alias eth0 tulip
alias eth1 tulip
#
options eth0            options=0
options eth1            options=0
#

---------------------------------------------
/etc/hosts

127.0.0.1         localhost
192.168.2.1     machine-1.linuxnet.de          machine-1    # my desktop system
192.168.2.2     linuxsystem.linuxnet.de         linuxsystem    # my server
192.168.2.3     machine-3.linuxnet.de          machine-3    # my windoze :-)
192.168.3.1     bardioc.universal.net           bardioc          # eth1/server
192.168.3.2     ganerc.universal.net            ganerc           # dialup server


----------------------------------------------
/etc/route.conf

# my personal configurations --------------------------------------
# internal net/first netcard
192.168.2.0             0.0.0.0                 255.255.255.0           eth0
#
# loopback 
127.0.0.0               0.0.0.0                 255.255.255.0           lo
#
# 
#
#
#
#
# way to the dialup server/second netcard
#
192.168.3.0             0.0.0.0                 255.255.255.0           eth1
#
default                 192.168.3.2
#

---------------------------------------------------
output of lsmod

tulip              7            2 (autoclean)
dummy0             1            1 (autoclean)
memstat            1            0
Module         Pages    Used by


some messages from dmesg/new installation on second hd

Linux version 2.2.14 (root@Pentium.suse.de) (gcc version 2.95.2 19991024 (release)) #1 Mon Mar 13 10:51:48 GMT 2000
Detected 400956037 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 799.54 BogoMIPS
Memory: 322220k/327680k available (1416k kernel code, 416k reserved, 3564k data, 64k init, 0k bigmem)
Dentry hash table entries: 65536 (order 7, 512k)
Buffer cache hash table entries: 524288 (order 9, 2048k)
Page cache hash table entries: 131072 (order 7, 512k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: L1 I Cache: 32K  L1 D Cache: 32K
CPU: AMD AMD-K6(tm) 3D processor 
..
..
..
tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth0: Digital DS21140 Tulip rev 18 at 0xe400, 00:00:92:96:2C:A7, IRQ 10.
eth0: Old format EEPROM on 'Cogent EM100' board.  Using substitute media control info.
eth0:  EEPROM default media type Autosense.
eth0:  Index #0 - Media 100baseFx (#7) described by a 21140 non-MII (0) block.
eth0:  Index #1 - Media 100baseFx-FD (#8) described by a 21140 non-MII (0) block.
eth0:  Index #2 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
eth0:  Index #3 - Media 10baseT-FD (#4) described by a 21140 non-MII (0) block.
eth0:  Index #4 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
eth0:  Index #5 - Media 100baseTx-FD (#5) described by a 21140 non-MII (0) block.
eth1: Digital DC21041 Tulip rev 17 at 0xe800, 00:00:F8:00:EF:C6, IRQ 5.
eth1: 21041 Media table, default media 0000 (10baseT).
eth1:  21041 media #0, 10baseT.
eth1:  21041 media #4, 10baseT-FD.
eth0: Using user-specified media 100baseTx.
eth1: 21143 10baseT link beat good.
Installing knfsd (copyright (C) 1996 okir@monad.swb.de)
nfsd_fh_init : initialized fhcache, entries=512
eth1: 21041 transmit timed out, status fc260000, CSR12 000050c8, CSR13 ffffef01, CSR14 ffffffff, resetting...
eth1: 21143 10mbps sensed media.
exp_do_unexport: 03:48 last use, flushing cache
exp_do_unexport: 03:47 last use, flushing cache
nfsd: terminating on signal 9
nfsd: terminating on signal 9
nfsd: terminating on signal 9
nfsd: terminating on signal 9
nfsd: last server exiting
nfsd_fh_shutdown : freeing 512 fhcache entries.
tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth0: Digital DS21140 Tulip rev 18 at 0xe400, 00:00:92:96:2C:A7, IRQ 10.
eth0: Old format EEPROM on 'Cogent EM100' board.  Using substitute media control info.
eth0:  EEPROM default media type Autosense.
eth0:  Index #0 - Media 100baseFx (#7) described by a 21140 non-MII (0) block.
eth0:  Index #1 - Media 100baseFx-FD (#8) described by a 21140 non-MII (0) block.
eth0:  Index #2 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
eth0:  Index #3 - Media 10baseT-FD (#4) described by a 21140 non-MII (0) block.
eth0:  Index #4 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
eth0:  Index #5 - Media 100baseTx-FD (#5) described by a 21140 non-MII (0) block.
eth1: Digital DC21041 Tulip rev 17 at 0xe800, 00:00:F8:00:EF:C6, IRQ 5.
eth1: 21041 Media table, default media 0000 (10baseT).
eth1:  21041 media #0, 10baseT.
eth1:  21041 media #4, 10baseT-FD.
eth1: 21143 10baseT link beat good.
lockd_up: no pid, 2 users??
nfsd_fh_init : initialized fhcache, entries=512
eth1: 21041 transmit timed out, status fc260000, CSR12 000050c8, CSR13 ffffef01, CSR14 ffffffff, resetting...
eth1: 21143 10mbps sensed media.

please answer me directly since im (not yet) on the mailinglist

....and 

Thanks for your help

Frank


--
"No one said it would be easy"

frank@lugh.de

www.lugh.de