[tulip] Re: lne100tx v4.1, Precompiled driver, Hangs

Paul M. James jamespa@qwest.net
Mon, 16 Jul 2001 10:35:03 -0600

> Message: 1
> Date: Fri, 13 Jul 2001 16:52:29 -0600
> From: "Paul M. James" <jamespa@qwest.net>
> To: tulip@scyld.com
> Subject: [tulip] lne100tx v4.1, Precompiled driver, Hangs
> Hello all,
> I'm stymied.  I have installed the precompiled tulip driver rpm for
> RH7.0.
> I did a clean install  without the card.  Installed the rpm, installed
> the card, configured with `netcfg`, edited  /etc/modules.conf and added
> the lines:
> 'alias eth0 tulip'
> 'options tulip debug=1 options=3,1 full_duplex=1,0 '

I cycled through a bunch of different options.  I realized  that the
second set of options refers to a second card after I finally found the
page refering to the option settings.  I am still not sure what is
optimal.  The file currently is set to:
	alais eth0 tulip
	options tulip debug=1 options=3 full_duplex=1

After each change I shut down the network and removed tulip and pci-scan
modules using:
	ifdown eth0
	rmmod tulip
	rmmod pci-scan
Does the machine need to be powered down to reset the card?

> restarted the network - '/etc/rc.d/init.d/network restart'
> no joy-- so I did:
> `insmod pci-scan`
> `insmod tulip`
	The modules are loading when I run the network restart script.
> then restarted the network again...
> I got the dialog:
> Setting network parameters:  [ok]
> Bringing up interface lo:    [ok]
> Bringing up interface eth0:     (at this point total system hang)

Same result.

> Any suggestions?  I am not as brilliant or as experienced as many of you
> who frequent this list, but I have been using Linux since RH 5.1.  This
> has me stumped. I would have switched cards long before now, but I have
> eight of these cards for my Beowulf project. (I am a computer science
> student.) The old version of the card worked great.
> Thanks so much for your time.
> Paul.
> please CC me.