[tulip] help forcing tulip onto given irq

Ari Jort arijort@valinux.com
Fri, 22 Sep 2000 06:18:49 -0400 (EDT)

I have a Tulip card from Kingston in an Intel L440GX board
and the nic keeps coming up on the same irq as the onboard
scsi controller.

I've tried the usual ways of politely coaxing the card
onto another irq, but it persists in its refusal.

I've tried adding 


in the relevant stanza in lilo.conf.

I've tried enter those parameters on the command line 
at the lilo prompt.

With a modular kernel, I've tried using irq=18 as parameter
for insmod tulip.  That's not an implemented parameter, it seems.
There is no load-time option on that driver to allow for setting 
the irq, I think.  Is that true?

The card keeps coming up on irq 19, shared with the scsi controller.

Moving the card to another slot had no effect also.

What am I missing?

Card identifies itself in dmesg:

tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth1: Digital DS21143 Tulip rev 65 at 0x2800, 00:C0:F0:4B:DE:7A, IRQ 19
eth1:  EEPROM default media type Autosense.
eth1:  Index #0 - Media MII (#11) described by a 21142 MII PHY (3) block.
eth1:  MII transceiver #1 config 3000 stats 782d advertising 01e1.

I also tried through ifconfig:

# ifconfig eth1 netmask irq 18 up
SIOCSIFMAP: Operation not supported

On which cards/drivers is setting the irq with ifconfig supported?

Thanks for any help,