[tulip] - Newbie - Problems with installing the tulip.o modul

Poly poly@mail.sisna.com
Wed, 6 Sep 2000 10:52:10 -0600

Hi David,
Sorry the change of OS did not help.  That means you have to go through the whole IRQ conflict document.  I did that also at some point.  At first it was kind of too much at the same time, but it makes more sense now.  I wish someone can elaborate more on that document and comment on some common case.

Before you dive into that, let's say that you are facing a problem that has many layers:
1. IRQ
2. Drivers
3. Network Configuration
and it also have to be solved in that order 1,2,3.  So, you first have to focus on solving the step 1.  I hope that the IRQ conflict document will help you solve the problem (read it carefully), if it doesn't and you need more help
then type the following commands and print out the result in to this mailing list.

dmesg | eth0

cat /proc/pci

cat /proc/interrupts 
It might also help to know what machine you have, someone out there might have the exact same machine.  Thanks.


---------- Original Message ----------------------------------
From: David Kramer <dkramer@Interelate.com>
Date: Tue, 5 Sep 2000 14:53:19 -0500 

>Thanks for the tip. I am receiving the same error IRQ assigned to IRQ 0.  I
>went into my system BIOS and changed the SO type to other.  I also
>unassigned IRQ 3, from the modem.  Unfortunately after making these changes
>I am still receiving the same error.  After you changed your OS type was
>there anything else that you did to make it work? 
>-----Original Message-----
>From: Poly [mailto:poly@mail.sisna.com]
>Sent: Tuesday, September 05, 2000 8:21 AM
>To: David Kramer
>Cc: tulip@scyld.com
>Subject: Re: [tulip] - Newbie - Problems with installing the tulip.o
>module fo
>Hi David,
>I have struggled with a similar problem for some time.  For a long time,
>netconf was telling me that my card was active while in fact it wasn't.
>ifconfig was also giving me the 
>SIOCSIFFLAGS: Resource temporarily unavailable
>SIOCADDRT: Network is down
>In my case, the problem was, there was no IRQ assigned (IRQ 0). You know
>that from doing 
>cat /var/log/messages | grep eth0  
>or dmesg | grep eth0  
>on a fresh install.  If it gives a value for IRQ other than 0, then youur
>problem is different.  Forget about this e-mail.  If it gives IRQ 0, it
>means you don't have an IRQ assigned.
>I was suggested many things to try in order for the system to assign an IRQ
>to the card.  Finally I had to make one change in my BIOS.  My computer has
>a place where the OS=Win95/98... with the option of changing that to
>Win2000, or NT or Other.  I changed that to Other, and my computer (which is
>dual boot) works well as a Windows98, or a Linux machine.  I hope this
>helps.  I still have to learn about the theory behind all that, but it did
>work for me a lot of frustration.  Thanks.
>---------- Original Message ----------------------------------
>From: David Kramer <dkramer@Interelate.com>
>Date: Sun, 3 Sep 2000 17:15:15 -0500 
>>I am new to Linux and using the tulip.o drivers.  All of my drivers and
>>headers files are the most recent from the SCYLD website.  I have compiled
>>my Tulip.c and pci-scan.c files I think correctly (used commands from the
>>end of the file).  However, when I run the depmod -a command from the net
>>modules directory I receiving an error message back:  
>>modprobe: not an ELF file
>>modprobe: not an ELF file
>>When I use the Depmod command seperately on the pci-scan.o it seems to work
>>fine, but when I depmod tulip.o I get back an unresolved symbol(s) message.
>>I dont understand what this is telling.  
>>Now when I modprobe both the tulip and the pci-scan and then use the lsmod
>>command both show up, the pci-scan is used by the tulip but the tulip isnt
>>used yet.  After this I run the ifconfig command but my eth0 doesnt show.
>>When I use the ifup command on eth0 I receive the following error message:
>>SIOCSIFFLAGS: Resource temporarily unavailable
>>SIOCADDRT: Network is down
>> I am really not sure what else to do and Linksys tech support isnt much
>>help.  If anyone could provide any insight I would GREATLY appreciate it.
>>David Kramer
>>tulip mailing list
>tulip mailing list