[tulip] SMC EZ Cardbus 10/100 Problem

Richard Atterer atterer@informatik.tu-muenchen.de
Thu, 8 Jun 2000 19:05:06 +0000


On Wed, Jun 07, 2000 at 09:22:49PM +0000, Scott W. Turner wrote:
>    I have a smc ez cardbus 10/100 ethernet card
>    and am having trouble getting it to work.
[snip]
>             3) card "SMC EZ 10/100 Fast Ethernet"
>                manfid 0x01bf, 0x2225
>                bind "tulip"

I've got one of these as well, but so far have been unable to get it
to work with any of the available drivers. Since I got my card, one
other person using it turned up on this list. He (but not I) was able
to get things to work with tulip-0.91x-ppc, a hacked version of the
tulip driver supplied with pcmcia-cs.

To make pcmcia-cs recognize the card, you need to tell it about the
changed ID: Copy the entry for the SMC from /etc/pcmcia/config to
config.opts and change the 0x2220 to 0x2225.

> This document contains confidential information of Marconi Commerce
> Systems,Inc. In consideration of the receipt of this document, the
> recipient agrees not to reproduce, copy, use or transmit this
> document and/or the information contained herein, in purpose except
> with written permission, first obtained, of Marconi Commerce
> Systems, Inc. and further agrees to surrender the same to Marconi
> Commerce Systems, Inc. upon demand.

You will not make any new friends posting this kind of stuff to
Linux-related lists/newsgroups. In fact, it very nearly caused me not
to reply to your message.

Cheers,

  Richard

-- 
  __   _
  |_) /|  Richard Atterer (currently at Queen's University, Belfast, NI)
  | \/|  http://www.in.tum.de/~atterer/
   `