Compiling 0.91x for SMC EZ 10/100 CardBus

Richard Atterer atterer@informatik.tu-muenchen.de
Wed Jan 12 14:43:56 2000


Hello,

I have recently bought an SMC EZ 10/100 CardBus card (exact model is
8034TX), which unfortunately wasn't supported by the pcmcia-cs-3.0.14
even though Dave Hinds' web page said so. (There appears to have been
a minor revision change - the ID string has also changed.)

With the old version from the PCMCIA package I had the 'Tx timeout'
problem which I see appears a lot in the mailing list archives.

Next I tried the 0.91g version, with no success whatsoever. In
particular, the card's 'active/link' LED stays off, and the
corresponding LED on the hub I'm connecting to also stays off.

The next thing I tried was the 0.91g2 version from suse.cz. Now the
'link/active' LED stayed on permanently, and the system log reported
'no heartbeat'.

Finally, I've been trying to compile the 0.91x version from
<ftp://cesdis.gsfc.nasa.gov/pub/linux/drivers/kern-2.3/>.
Unfortunately, this doesn't work and I've been unable to track down
the problem. When I try to compile the driver this happens:

kern-2.3> make PCMCIA=/home/richard/software/pcmcia-cs-3.0.14/include tulip_cb.o
cc -DCARDBUS -I/usr/include/ -I/home/richard/software/pcmcia-cs-3.0.14/include -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -O6 -DMODVERSIONS -c tulip.c -o tulip_cb.o
tulip.c: In function `tulip_attach':
tulip.c:3279: parse error before `pci_read_config_dword_R2ca7e89f'
tulip.c:3266: warning: `pdev' might be used uninitialized in this function
tulip.c:3269: warning: `pciaddr' might be used uninitialized in this function
make: *** [tulip_cb.o] Error 1

(NB the README is wrong, you need to use PCMCIA=..., not
CARDBUS=... to compile the CardBus versions.)

My suspicion is that I need a developer kernel - is this correct? The
above happens with a 2.2.13 kernel.

Many thanks for your help,

  Richard

-- 
  __   _
  |_) /|  Richard Atterer (currently at Queen's University, Belfast, NI)
  | \/|  http://www.in.tum.de/~atterer/
   ` 
-------------------------------------------------------------------
To unsubscribe send a message body containing "unsubscribe"
to linux-tulip-request@beowulf.org